[[informationen:blog:abschliessender-zeilenvorschub-fehlt-in-dateilisten-datei-des-paketes]]

dpkg: nicht behebbarer fataler Fehler, Abbruch

Fehlermeldung komplett:

dpkg: nicht behebbarer fataler Fehler, Abbruch:
Abschließender Zeilenvorschub fehlt in Dateilisten-Datei des Paketes »linux-modules-4.15.0-64-generic«
E: Sub-process /usr/bin/dpkg returned an error code (2)

Abhilfe schafft das verschieben der Moduldateien

drei@Service10:~$ sudo mv /var/lib/dpkg/info/linux-modules-4.15.0-64-generic.list /tmp/
drei@Service10:~$ sudo mv /var/lib/dpkg/info/linux-modules-4.15.0-64-generic.postrm /tmp/

danach ein komplettes Upgrade

drei@Service10:~$ sudo dpkg --configure -a
drei@Service10:~$ sudo apt update
OK:1 http://linux.teamviewer.com/deb stable InRelease
Ign:2 http://mirrors.evowise.com/linuxmint/packages tessa InRelease                                                                                                     
OK:3 http://artfiles.org/ubuntu.com bionic InRelease                                                                                                                    
OK:4 http://ppa.launchpad.net/nextcloud-devs/client/ubuntu bionic InRelease                                                                                             
OK:5 http://download.virtualbox.org/virtualbox/debian bionic InRelease                                                                                                  
OK:6 http://artfiles.org/ubuntu.com bionic-updates InRelease                                                                                                            
Holen:7 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]                                                                                           
OK:8 http://mirrors.evowise.com/linuxmint/packages tessa Release                                                                                                        
OK:9 http://artfiles.org/ubuntu.com bionic-backports InRelease                                                                                                          
OK:10 https://repo.skype.com/deb stable InRelease                                                                                                                       
OK:11 http://archive.canonical.com/ubuntu bionic InRelease                                                     
Es wurden 88,7 kB in 2 s geholt (48,6 kB/s).        
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Aktualisierung für 4 Pakete verfügbar. Führen Sie »apt list --upgradable« aus, um sie anzuzeigen.
drei@Service10:~$ sudo apt upgrade
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  dkms firefox firefox-locale-de firefox-locale-en
4 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen noch 0 B von 51,4 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 5.197 kB Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 369716 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../dkms_2.3-3ubuntu9.7_all.deb ...
Entpacken von dkms (2.3-3ubuntu9.7) über (2.3-3ubuntu9.5) ...
Vorbereitung zum Entpacken von .../firefox_70.0+linuxmint1+tina_amd64.deb ...
Entpacken von firefox (70.0+linuxmint1+tina) über (69.0.3+linuxmint1+tina) ...
Vorbereitung zum Entpacken von .../firefox-locale-de_70.0+linuxmint1+tina_amd64.deb ...
Entpacken von firefox-locale-de (70.0+linuxmint1+tina) über (69.0.3+linuxmint1+tina) ...
Vorbereitung zum Entpacken von .../firefox-locale-en_70.0+linuxmint1+tina_amd64.deb ...
Entpacken von firefox-locale-en (70.0+linuxmint1+tina) über (69.0.3+linuxmint1+tina) ...
firefox-locale-en (70.0+linuxmint1+tina) wird eingerichtet ...
dkms (2.3-3ubuntu9.7) wird eingerichtet ...
firefox (70.0+linuxmint1+tina) wird eingerichtet ...
Please restart all running instances of firefox, or you will experience problems.
firefox-locale-de (70.0+linuxmint1+tina) wird eingerichtet ...
Trigger für mime-support (3.60ubuntu1) werden verarbeitet ...
Trigger für desktop-file-utils (0.23+linuxmint5) werden verarbeitet ...
Trigger für mintsystem (8.4.2) werden verarbeitet ...
Trigger für man-db (2.8.3-2ubuntu0.1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.17-2) werden verarbeitet ...
drei@Service10:~$

Sollten weitere Dateien diesen Fehler machen, diese auch noch verschieben. Auf diesem Laptop waren es

linux-modules-4.15.0-58-generic
linux-modules-4.15.0-60-generic
linux-modules-4.15.0-62-generic
linux-modules-4.15.0-64-generic